Increased loading times expected for keyword rankings features
Incident Report for SE Status
Resolved
For most users the speed on keyword related feature pages should now load at normal speed, which is why we are setting this status to solved.

Large customers with a lot of asins/keywords may still experience longer loading times. We are continuing to work on this.
Posted Aug 06, 2019 - 18:03 CEST
Update
We have had some breakthroughs in the backend to generally speed up all rankings related features, though there are still occurences of prolonged loading times.

We are continuing to work on this from all angles!
Posted Jun 14, 2019 - 14:09 CEST
Monitoring
The switch to the parent based rankings (by default) has been completed. There is still some restructuring work to be done for the database though, so for now the loading times are still expected to remain quite high, unfortunately.

We thank you again for your patience and hope to have this solved asap!
Posted May 24, 2019 - 12:09 CEST
Identified
In light of certain changes made by Amazon (and because we feel it makes more sense anyway), we are preparing a switch in how Rankings are displayed for your products.

Currently, under "Rankings", as well as "Current Ranking" in your product dashboards, Sellics shows the specific ranking of the Child ASIN (variation) you are looking at. This specific child ASIN is, however, often not actually ranking for the respective keywords. This makes it look like your product is not found, when in truth customers simply find another variation in the search results, which basically leads to the same outcome.

Sellics will therefore soon, by default, only show rankings of the best ranked variation for each child ASIN. This is quite a big structural change in our backend and will require a few days to complete - it may also lead to increased loading times for keyword data.

Apoligies for any inconvenience caused by this and thank you for your patience!
Posted Apr 11, 2019 - 12:18 CEST
This incident affected: Sellics Seller Edition (Keyword Rankings).